QuiteRSS doesn't update news after standby on ArchLinux

16 posts / 0 new
Last post


Since version 17.x, QuiteRSS doesn't update news after a standby on ArchLinux. I can quit QRss and reopen and new news will be downloaded. However, after the system goes into standby again, again QRss won't update the news anymore. I have been hoping with each update that the problem would magically disappear, but alas...

How would I be able to fix this, apart from restarting QuiteRSS everytime the system comes out of standby? What information could I provide so that some of you could help me fix this?



did you enable the option

"Store a db in memory"


Tools -> Options -> General?

if so try to run QuiteRss with this option disabled.

Kind regards,




I am giving at a try and it seems to work...I will update tomorrow whether the issue is truly resolved.

After rebooting QuiteRSS now

After rebooting QuiteRSS now starts minimized in the taskbar and exits after mere seconds. 

Running the terminal generates: "Segmentation fault (core dumped)"

The result of "gdb quiterss", run:

"gdb) run
Starting program: /usr/bin/quiterss
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffe4bb1700 (LWP 28836)]
[New Thread 0x7fffd3cfd700 (LWP 28837)]
[New Thread 0x7fffd30e5700 (LWP 28838)]
[New Thread 0x7fffd26dc700 (LWP 28839)]
[New Thread 0x7fffd1be7700 (LWP 28840)]
[New Thread 0x7fffd13e6700 (LWP 28841)]
[New Thread 0x7fffd0be5700 (LWP 28842)]
[New Thread 0x7fff8bdc0700 (LWP 28843)]
[New Thread 0x7fff8b5bf700 (LWP 28844)]
[New Thread 0x7fff8a06c700 (LWP 28845)]
[New Thread 0x7fff8986b700 (LWP 28846)]
[New Thread 0x7fff8906a700 (LWP 28847)]
[New Thread 0x7fff88869700 (LWP 28848)]
[New Thread 0x7fff637fc700 (LWP 28849)]
[New Thread 0x7fff62ffb700 (LWP 28850)]

Program received signal SIGSEGV, Segmentation fault.
0x00000000004c268e in ?? ()"

I've put a fuller debug log here.

Can't find the log location. Does anybody know where QuiteRSS writes its log?

Take a look at the file debug

Take a look at the file debug.log in the QuiteRss dir.
Maybe in your case it's stored in the user dir.

Found it. Thanks. It's a

Found it. Thanks. It's a rather repetitive series of warnings. The debug.log.

Not much help at suggesting what the reason for the segmentation fault is. Can I enable extra logging from the command line?

Unfortunately not! But there

Unfortunately not! But there are some known memory issues on several linux versions.
Maybe it's not directly related to QuiteRss but to the os. Did you check that?

How would I check that? I

How would I check that?

I looked through the journal ("journalctl -S 2015-02-15") and the only things in red are bluetooth (can't connect to a gadget that isn't in the room) and QuiteRSS's core dump. Those dumps are identical to the log generated with dbg.

I shortly cross-checked the

I shortly cross-checked the ArchLinux forum and found f.e. this https://bbs.archlinux.org/viewtopic.php?id=208330 This is what I meant. This memory issues seem to be reported already. Maybe it's worth to have a deeper look at this.

Thanks for the link.

Thanks for the link.

I checked the memory used with pm_mem and nothing is out of the ordinary. I switched desktops to Xfce and QuiteRSS still crashes.

So that hypothesis seems shot.

Honestly I am running out of

Honestly I am running out of ideas.
You could try to reinstall QuiteRss. Don't forget to backup your data before doing that.

Unfortunately, in some cases,

Unfortunately, in some cases, after the standby mode, the application can not use the network connection.

@Sheldon I renamed  ~/.local

@Sheldon I renamed  ~/.local/share/QuiteRSS to something else and it starts again. So probably the something got corrupted. Any way to get the feeds from the apparently corrupted dataset?

@Funcy-dcm Any way that I can tweak that?


EDIT: Yes, it's feeds.db that's corrupted. I'll try deleting the newsrecords in the database and hope the error is in there.
EDIT2: Nope. Database is still gives reason to crash. Then I'll try copying the feed records to the working database.

Maybe the db is corrupted.

Maybe the db is corrupted.

If you start your old Quiterss you can export the feeds via

File -> Export feeds...

and import them to the new QuiteRss via

File -> Import feeds..

The related data will be downloaded aagain.

If the special data is important to you can also perform a dump on the feeds.db.

Via sql command you can import the data to the new feeds.db.


By copying the QuiteRss.ini from the old QuiteRss to the new one you get your settings back.

@Sheldon Uhh, I never see the

@Sheldon Uhh, I never see the old one quite long enough to do any clicking, let alone exporting. That's why I am playing around with SQLiteBrowser.

EDIT: Nope, exporting the feeds table to a csv-file and importing it again in the newly created feeds.db doesn't work either.

EDIT2: It was one line of the feeds table that crashed it all. The backup automatically made two weeks ago was working, too. Should have tried that first.

Stupid, should have kept it simple. Still, at least now I know how to use SQLiteBrowser. It's neat. Anyhow, I deleted the feed line, which was a directory and pointed  newsfeed in it to a different directory. Everything works again.



I will test whether it works with Sheldon's suggestion without further db corruption. Still no idea how the internet connectivity for QuiteRSS after standby can be checked or enabled.

I've opened a question in

I've opened a question in Arch Linux Newbie forum, too.


As expected there is no further corruption, nor internet connectivity for QuiteRSS after coming back from suspend.