Cannot delete old news

13 posts / 0 new
Last post

Hi there,

For some reason my QuiteRSS doesn’t purge deleted news or enforce options such as 'Maximum age' or 'Number of news to keep'.

Manually deleting news seems to move them to an invisible trash folder but they are never removed. The database file has grown to 0.5G which makes the program rather unwieldy.  If I run the Clean Up wizard it always reports “0 news deleted”, no matter the setting.

Any suggestions as to what might be wrong?
I’m using Linux, Manjaro, KDE Plasma 5.

Thanks!

Hi,

Hi,

it seems like your feeds.db is corrupted. Please get SQLiteExpert from

http://www.sqliteexpert.com/

, open the feeds.db

and check under

Database -> Check.

Kind regards,

Sheldon

Thanks for replying Sheldon.

Thanks for replying Sheldon.

Being on Linux I used sqlite3:

sqlite3 ~/.local/share/QuiteRss/QuiteRss/feeds.db "PRAGMA integrity_check"

Which reported no errors. I repaired the .db anyway with:

echo '.dump'|sqlite3 feeds.db|sqlite3 feed_rep.db

That reduced the db size slightly but otherwise didn’t help either. Out of curiousity I renamed the db-file and started fresh, then tried running the cleanup tool on the QuiteRSS feed only, but it still reports “0 news deleted”.

Thinking there could be a problem with Manjaro’s package I tried AUR’s instead, compiling from source, but no luck.

I’m not sure what’s going on. If there are any Linux users out there I’d be interested in hearing their experience.

Cheers!

Try this query using sqlite3

Try this query using sqlite3.exe.

Select count(*) from news where deleted = 2

What does it say?

$ sqlite3 ~/.local/share

$ sqlite3 ~/.local/share/QuiteRss/QuiteRss/feeds.db "Select count(*) from news where deleted = 2"
31272

Quite a few.  Smile

Please run

Please run

Delete from news where deleted = 2

and a vacuum command afterwards.

Hmm, no change. I tried

Hmm, no change. I tried removing ~/.config/QuiteRss, ~/.local/share/QuiteRss/ and ~/.cache/QuiteRss for a completely clean install but cleanup still doesn’t work. 

Anyway, I think you shouldn’t spend more time on this, I also have Akregator and will use that until I replace my system in the near future. I do sometimes experience write lockups with the /home partition so there may be a hardware issue. After the upgrade I’ll come back to QuiteRss. Thanks Sheldon and sorry for the bother.

Cheers!

I'm having the same problem.

I'm having the same problem.sad

I'm running Linux Debian (Buster). QuiteRSS has been running well and deleting old news properly until I did a system update two weeks ago. Since then I'm unable to delete old news either manually or automatically on exit, my feeds.db has been growing constantly.

I have tried all the above advice and feeds.db seems to check out ok using sqlite3.

Reverting to the previously working version of QuiteRSS did not solve the problem.

Checking the debug.log I find the following two lines after each attempt to delete old news:

WARNING: QSqlDatabasePrivate::database: requested database does not belong to the calling thread.
WARNING: QSqlQuery::exec: database not open

This is odd. news items are being added to the database properly so it is clearly open.

Do you have any more suggestions. This seems such a small point but it will soon make QuiteRSS unusable.

 

You're right. My debug.log is

You're right. My debug.log is also mainly populated with this line:

WARNING: QSqlQuery::exec: database not open

interspersed with a few of these:

WARNING: QSqlDatabasePrivate::database: requested database does not belong to the calling thread.

I forwarded this issue to our

I forwarded this issue to our project manager.

Send me settings file and a

Send me settings file and a screenshot of window "Menu - help - about - information". 

OK. Where would you like me

OK. Where would you like me to send them?

egor.shilyaevgmail.com

egor.shilyaevatgmail.com