Стало невозможно установить QuiteRSS на CentOS 6

23 posts / 0 new
Last post

Парни, теперь стало невозможно установить QuiteRSS на CentOS 6.

В родных репах CentOS его нет, в федоровских  он тоже исчез -
http://mirror.yandex.ru/fedora/russianfedora/russianfedora/free/el/relea...

Поэтому рецептура установки на http://pkgs.org/centos-6/russian-fedora-free-updates-i386/quiterss-0.10....

  1. Download the latest russianfedora-free-release rpm from
    http://mirror.yandex.ru/fedora/russianfedora/russianfedora/free/el/relea...
     
  2. Install russianfedora-free-release rpm:
    # rpm -Uvh russianfedora-free-release*rpm
     
  3. Install quiterss rpm package:
    # yum install quiterss

совершенно не срабатывает.

Как быть?

Все, разобрался! Вернее,

Все, разобрался! Вернее, помог разобраться Николай aka lystor.

Но все-таки абидно, что для CentOS 6 есть только старая версия QuiteRSS v.0.10.1  - аж за 2012 год! crying

Попробуйте взять отсюда: http

Попробуйте взять отсюда: http://software.opensuse.org/package/quiterss?search_term=quiterss
или из официальной репы Fedora (не из репы Russian Fedora)

Да как-то не хочется ставить

Да как-то не хочется ставить сюсевское на ЦентОС. А Федоровские НЕ русские репо - это где?

Хотелось бы ставить по нормальному - по yum install, а не по rpm i

Цитата:Да как-то не хочется

Quote:
Да как-то не хочется ставить сюсевское на ЦентОС.

Выше по ссылке есть пакеты на федору 20, 21. Ещё есть здесь: http://pkgs.org/download/quiterss

Quote:
А Федоровские НЕ русские репо - это где?

Я в линукс не разбираюсь, но мне сказали что в официальной репе федоры есть и должно работать по нормальному - yum install quiterss

И исправьте, пожалуйста, на

И исправьте, пожалуйста, на вашей странице ссылки на скачивание - они не работают:

Скачать > QuiteRSS для других ОС > Russian Fedora > QuiteRSS доступен для Fedora из официального репозитория > Мы переехали! >

и дальше, какую ссылку из этих не нажмешь -

russianfedora.RU -> russianfedora.PRO
forum.russianfedora.RU -> forum.russianfedora.PRO
redmine.russianfedora.RU -> redmine.russianfedora.PRO
wiki.russianfedora.RU -> wiki.russianfedora.PRO
koji.russianfedora.RU -> koji.russianfedora.PRO

- никаких QuiteRSS или репо здесь не наблюдается.

И еще. На странице "Скачать" упомянуты ОС - Windows, MacOS - это ходовые ОС.
А FreeBSD, которой мало кто пользуется, и особенно древнючая OS2 - кому они здесь надо?

И в тоже время одна из популярных ОС как Linux у вас засунута в "QuiteRSS для других ОС".
Это совершенно не логично Sad

> Ещё есть здесь: http://pkgs

> Ещё есть здесь: http://pkgs.org/download/quiterss

Там старая версия v.0.10.1, писал выше об этом.

А на сюсевском сайте тоже нет свежих версий, только 0.14.3-1.1

Цитата:Там старая версия v.0

Quote:
Там старая версия v.0.10.1, писал выше об этом.

Я про версию для федоры, конкретно для федоры 20, 21 там 0.17.6

Цитата:А на сюсевском сайте

Quote:
А на сюсевском сайте тоже нет свежих версий, только 0.14.3-1.1

0.17.6

Цитата:И еще. На странице

Quote:
И еще. На странице "Скачать" упомянуты ОС - Windows, MacOS - это ходовые ОС. А FreeBSD, которой мало кто пользуется, и особенно древнючая OS2 - кому они здесь надо?

В разделе "Скачать" размещены ссылки на файлы, которые хранятся у нас на сервере

Уже скачал и установил 0.17.6

Уже скачал и установил 0.17.6 отсюда - https://build.opensuse.org/package/binary/X11:QtDesktop:trunk/quiterss?a...

командой yum localinstall quiterss-0.17.6.3504-2.1.i686.rpm

И был изумлен - установленная "новая" версия тоже оказалось старой - 0.10.1 surprise

Ладно, тогда скачиваю репу

wget http://download.opensuse.org/repositories/X11:QtDesktop:trunk/Fedora_21/...

и устанавливаю по yum install quiterss

- и тоже версия 0.10.1 crying

Это что же, сюсевцы нас дурачат??

В-общем, оказалось, что даже

В-общем, оказалось, что даже после деинсталляции QuiteRSS в домашнем каталоге в каталогах ~/.config/QuiteRSS  и ./local/share/data

остаются старые конфигурационные файлы и базы, котыре мешаю запуску новых версий.

Почистил их вручную и устновил заново quiterss-0.17.6.3504-2.1.i686.rpm

Похоже, чистка остатков старой 0.10.1 помогла, потому что старая версия не запустилась.

Но не запустилась и новая - при запуска в консоли видна причина:

quiterss
quiterss: symbol lookup error: quiterss: undefined symbol: _ZN9QListData11detach_growEPii

Какое же дерьмо эти новые сусевские сборки! Придется возвращаться к старой.

 

Господа разработчики,

Господа разработчики, соберите, пожалуйста, нормальную свежую сборку QuiteRSS под CentOS 6! cheeky

Потому что работа даже старого QuiteRSS очень понравилась, представляю, что будет с новым wink

Да - после установки quiterss

Да - после установки quiterss-0.14.3-1.1.i686.rpm запуск его тоже дает ошибку:

quiterss: symbol lookup error: quiterss: undefined symbol: _ZN9QListData11detach_growEPii

Так что сюзевцы еще те криворукие кодеры no

Наверное, придятся опять возращаться на Liferea - старый конь борозды не портит.

 

Для федоры: http://pkgs.org

Для федоры: http://pkgs.org/fedora-20/fedora-updates-i386/quiterss-0.17.6-1.fc20.i68...

Попрошу мейнтейнера федоры, чтобы помог сделать сборку под CentOS 6. Но не уверен что он сможет.

" Для федоры: http://pkgs.org

" Для федоры: http://pkgs.org/fedora-20/fedora-updates-i386/quiterss-0.17.6-1.fc20.i68... "

Об этих федоровских сборках здесь я неоднократно отмечал - они неработают в CentOS 6.

Что до сборщика: не поленится, сделает - это хорошо, еще не один пользователь QuiteRSS прибавится, не сделает - уйдут на другие агрегаторы.

Вообще не пойму: делают QuiteRSS для такой глюкавой и экстремальной оси как Федора, а высокостабильный ЦентОС игнорируют - где логика?

Сборки для сусе и федоры

Сборки для сусе и федоры делают мейнтейнеры, а не разработчики, т.е. заинтересованые пользователи, которым необходим QuiteRSS для своей ОС. Для ЦентОС никого не нашлось - за три года никто не спрашивал пакетов для этой ОС.

Для ЦентОС никого не нашлось

Для ЦентОС никого не нашлось - за три года никто не спрашивал пакетов для этой ОС.

Мне жаль этих пользователей - они пропустили самое вкусное laugh

Всё, разобрался - в CentOS 6

Всё, разобрался - в CentOS 6 qt версии 4.6.х, а QuiteRSS поддерживает Qt >= 4.7.4. Соответственно сборку через стандартные методы не получить.

В каком смысле "через

В каком смысле "через стандартные" ?

Я имею ввиду, что без

Я имею ввиду, что без установки CentOS 6 и выполнения некоторых нетривиальных действий не получить готовый пакет QuiteRSS. А для других ОС можно воспользоваться специальными ресурсами.

Чтобы заработал QuiteRSS для

Чтобы заработал QuiteRSS для федоры под центос вам необходимо обновить пакеты qt до версии 4.8.5

Это будет так же трудно, как

Это будет так же трудно, как заставить работать феодоровскую  quiterss-0.17.6 под CentOS 6.

Потому что под CentOS новее пакетов QT, чем 4.6.x нету. А значит, их тоже надо собирать.

Но это еще хуже, чем собрать quiterss-0.17.6 под CentOS 6, потому что установка более новых QT, чем есть в системе, наверняка наружит ее баланс и связи, многие старые приложения откажутся запускаться.