Проблема с фильтром новостей в 0.18.3

4 posts / 0 new
Last post

Добрый день.

У меня перестали работать фильтры новостей в версии 0.18.3, Windows версия (на Windows 7).

Ленты "Компьютерра" - http://feeds.feedburner.com/ct_news и "Компьюлента" - http://feeds.feedburner.com/cl_news/

В них размещается реклама, в категории "в RSS"

Я делал фильтры на обе ленты одновременно и на каждую по отдельности, следующего вида:

Но они теперь не работают в автомате, только если запускать вручную (причем надо запустить пару-тройку раз).

Последняя рабочая версия была .0.18.1, в версии 0.18.2 периодически не работало, но затем запускалось и эти ленты очищались.

Другие фильтры для других лент работают без ошибок, только это две ленты проблемные.

 

Подскажите пожалуйста, как еще можно настроить фильтрацию, чтобы она работала для этих лент?

Или это потому что категория содержит русские и английские буквы? Остальные фильтры на одном языке, работает без ошибок.

 

Заранее благодарю за помощь.

Попробуйте версию 0.18.4

Попробуйте версию 0.18.4

Спасибо, заработало.

Спасибо, заработало.

Я поменял условия в правиле фильтра, с 'contains" на "begins with", иначе очищалось только частично.

 

Небольшая просьба: можно ли сделать в следующей версии возможность добавлять фильтры прямо из окна новостей.

Нажать правую клавишу на заголовке новости или категории или подобное, выбрать что-то вроде "Создать фильтр" и потом уже настроить фильтрацию. Сейчас приходится вручную создавать правило, вносить весь необходимый текст для фильтрации и прочее.

Спасибо за помощь, Funcy-dcm всего хорошего.

Добрый день еще раз, Funcy

Добрый день еще раз, Funcy-dcm.

Изменение условия фильтрации не очень помогло, новости с категорией "в RSS, EMC, XtremIO" все равно оставались в ленте. Но помогло небольшое изменение параметров:

- язык интерфейса поменял на русский, в фильтре создал отдельно условия "содержит" для "в RSS" и для "XtremIO"

- переместил сами фильтры, раньше они шли один за другим, теперь между ними стоят другие фильтры (хотя ленты так и остались в дереве, сначала Компьютерра, затем Компьюлента

На Windows 7 теперь работает без ошибок, на Windows 10 дома буду еще ковырять дальше.

 

С уважением,

rdigit