QuiteRSS freezes on import and update

6 posts / 0 new
Last post

I'm on Kubuntu Wily x64, Qt 5.5.1. QuiteRSS 18.2 installed via getdeb PPA.

Program freezes on opml import. When I force close and start it again, I see all feeds have been imported.

When I try to update feeds, program freezes. When I force close and start it again, I see feeds have been updated.

Once feeds are updated, I have no problems at all.

Tried to build previous version from source but got "Project ERROR: sqlite3 development package not found" message although I have sqlite3 and libsqlite3-dev packages installed.

Please advise.

Hi,

Hi,

this might be a problem with your database. Here some questions to clarify this.

What is the size of the file feeds.db?
How many feeds do you import via opml?

Kind regards,

Sheldon

Hi Sheldon. Thank You for

Hi Sheldon. Thank You for answering.

I'm importing 20 feeds. Akregator and RSSOwl open .opml and update without problem.

I've uninstalled QRSS but just found that config folder remained leaving 2 files: feeds.db sized 52 kb and debug.log.

debug.log

28.11.2015 22:28:38.316 WARNING: Run application!
28.11.2015 22:28:38.402 WARNING: Creating database
28.11.2015 22:28:39.399 WARNING: sqliteDBMemFile(): from file to memory...
28.11.2015 22:28:39.400 WARNING: sqliteDBMemFile(): finished!
28.11.2015 22:28:39.401 WARNING: Run application 2
28.11.2015 22:28:39.538 WARNING: AdBlockSubscription:: loadSubscription invalid format of adblock file "/home/korisnik/.local/share/QuiteRss/QuiteRss/adblock/customlist.txt"
28.11.2015 22:28:39.573 WARNING: Run application 3
28.11.2015 22:28:39.619 WARNING: Run application 4
28.11.2015 22:28:39.622 WARNING: Run application 5
28.11.2015 22:28:39.707 WARNING: Run application 6
28.11.2015 22:29:16.673 WARNING: KSambaShare: Could not find smb.conf!
28.11.2015 22:30:22.621 WARNING: "Parse data error (2): url http://feeds.feedburner.com/computerarts/news, id 23, line 51, column 13: tag mismatch"

So I guess that parse data error is culprit? 

Ket's try this. Just delete

Let's try this. Just delete the feed for http://feeds.feedburner.com/computerarts/news and add it manually afterwards.
I tried it and QuiteRss couldn't receive data. So it's a problem with this feed. It seeems to be outdated or the url is not correct.
Please check!

Do you mean this feed http://feeds.feedburner.com/creativebloq/? That works fine.

Sheldon, I really appreciate

Sheldon, I really appreciate the effort.

I meant computerarts feed. I deleted it and tried import. QRSS froze and failed to import.

I then imported all my feeds (except that one) manually. When I add them QRSS updates them without question. That went well.

I thought it will be OK. And I was wrong! Right clik on the folder->update feed... QRSS freezes.

QRSS worked on my another Plasma 5 - Manjaro Linux, so I cant blame QRSS for this behaviour, but I think that it would be foolish to ignore Ubuntu errors since that is THE major distro.

QRSS is my chosen reader but I dont have time for this, so I'm going the RSSOwl way.

Thanks again, Sheldon.

 

Solved it, it's not a bug.

Solved it, it's not a bug.

Ubuntu uses package from Debian (quiterss_0.18.2+dfsg-1_amd64), as good people at Kubuntu forum told me.

It's not working in Kubuntu. On the other hand Your package from ppa for VIVID works perfect on Wily.

So problem is not on Your side.